Python 2.4 on Ubuntu 10.04

written on 2010-08-16

The installation of python2.4 on Ubuntu 10.04 had me pulling the hair from my head. I needed to deploy a Plone project using Fabric and buildout-source-release and python2.4, but the latter has been dropped for Ubuntu 10.04. Through dirty hacks it was possible to release, but now I've got the propper solution.

Using: http://plone.org/documentation/kb/installing-a-plone-buildout-on-ubuntu and http://davidjb.com/blog/2010/05/installing-python-2-4-on-ubuntu-10-04-lucid-lynx I finally ended up with:

# Jaunty 2.4 packages wget http://mirror.aarnet.edu.au/pub/ubuntu/archive/pool/main/p/python2.4/python2.4-minimal\\\_2.4.6-1ubuntu3.2.9.10.1\\\_i386.deb -O python2.4-minimal.deb wget http://mirror.aarnet.edu.au/pub/ubuntu/archive/pool/main/p/python2.4/python2.4\\\_2.4.6-1ubuntu3.2.9.10.1\\\_i386.deb -O python2.4.deb wget http://mirror.aarnet.edu.au/pub/ubuntu/archive/pool/main/p/python2.4/python2.4-dev\\\_2.4.6-1ubuntu3.2.9.10.1\\\_i386.deb -O python2.4-dev.deb sudo dpkg -i python2.4-minimal.deb python2.4.deb python2.4-dev.deb

# Setup tools wget http://peak.telecommunity.com/dist/ez\\\_setup.py sudo python2.4 ez_setup.py -U setuptools

# Clean up rm python2.4-minimal.deb python2.4.deb python2.4-dev.deb ez_setup.py

Update: After upgrading to Ubuntu 10.10 the instructions still seem to work.

Pagination